Product Logo

FTPit Pro

Transfer files to and from an FTP server


Install the plug-in

You have now downloaded the plug-in archive, unzipped it, and are ready to install the plug-in. The Windows plug-in does also require Microsoft’s .NET Framework and a C++ Redistributable Package that you may need to install if your computer does not already them.

Install the plug-in

To install the plug-in, simply open the Installer database and press the appropriate Install button. If you need access to the actual plug-in files, press the Save to Disk button or switch to the Plug-ins layout.


Microsoft’s .NET Framework v4.5.x

In order to use the Windows plug-in, you must have Microsoft’s .NET Framework version 4.5 installed on your computer. If you do not have this already installed on your computer, you will need to install it. If the Installer database gives you errors about the plug-in not loading or installing, continue following these instructions. The chart below shows the default versions of .NET that are installed on the various versions of Windows.

Default Installed .NET Versions
Windows VersionDefault .NET Version
Windows Vista, Windows Server 2008v3.0
Windows 7v3.5.1
Windows 8/8.1, Windows Server 2012v4.5
Windows 10v4.6

If you are unsure what versions of the .Net framework you have installed on your computer, Microsoft provides a webpage to help you determine which versions you have installed. You may also be able to go to the Control Panel in Windows, and then “Programs and Features” or “Add or Remove Programs” and see what versions you have installed. Note, this will only show versions you have installed and not the default version(s) that were included with Windows.

Install .NET 4.5

To install .NET 4.5, please see the instructions on Microsoft’s web site.

Note
If you have a newer version than .NET 4.5, the plug-in will still not appear in FileMaker. Unfortunately, because of the way .NET works, you must still have 4.5 installed even if you have a newer version installed. We are sorry for the inconvenience.

Microsoft Visual C++ 2017 Redistributable Package

The Windows plug-in also requires a redistributable package to be installed on your computer in order to work properly. It is common other software installer packages will install the redistributable, but if you have a system that is fairly new or does not have much installed on it, you may need to install the redistributable package as well.

If you are using a 64-bit version of FileMaker Pro, you will need the 64-bit plug-in and the 64-bit C++ Redistributable Package. If you are using a 32-bit version of FileMaker Pro, you will need the 32-bit plug-in and the 32-bit C++ Redistributable Package.

Note, the plug-in requires the 2017 version of the redistributable package even if you have a newer one installed.

64bit
https://aka.ms/vs/16/release/vc_redist.x64.exe
32bit
https://aka.ms/vs/16/release/vc_redist.x86.exe