Product Logo

POP3it Pro

Email downloading made easy.


Choosing which Plug-in to Use

Before you download the plug-in, you must decide which version of the plug-in will suit your needs. There are two choices; the client version and the server version.

Client Version

The client version of the plug-in is installed in FileMaker Pro (FMP) or Pro Advanced and allows that computer to use the plug-in. The plug-in must be installed on each FMP computer that needs to use it. The location of your databases do not matter, and can either be on the local computer or hosted by FileMaker Server (FMS). Even if your databases are hosted on FMS, you do not need the Server Version unless you need the functionality described below.

If you are going to use the Client Version, continue to the client plug-in download section.

Server Version

The Server Version (or Server Edition) of the plug-in allows you to install the plug-in on your FMS and use it with Server Scheduled Scripts (FMS 9+) or install it on your FMS Advanced to use it with Web Publishing (including custom/instant web publishing and WebDirect).

The Server Plug-in does not bypass the need to install the plug-in on your FMP client computers. If you have FMP client users that need to directly use the plug-in, the normal client plug-in must be installed on each FMP computer. This is not a restriction we added, but simply a result of how FMS works. FileMaker Server plug-ins simply give the Server the functionality of the plug-in and does not replace the plug-in on the FMP client computers.

FileMaker Server’s Auto Update functionality (FMS 11 and below) can help you distribute the client plug-in to your FMP computers. If you are using FMS 12 (or higher) and FMP 12 (or higher), you can use the “Install Plug-in File” script step to distribute the client plug-in to your FMP computers.

In order to write scripts for the Server plug-in to use, you must install the client plug-in in FMP on at least one computer. FileMaker Server does not give you the ability to create or edit scripts.

Server Version Exception

If you are using FMS 13 (or higher) and FMP 13 (or higher), you can use the “Perform Script on Server” script step to call a script from FMP to run on the FMS which utilizes the plug-in. This does allow you to use the Server plug-in from FMP without needing a client plug-in, but it may not provide complete functionality. Functions that need to be run on the local FMP computer will not work, such as functions that display dialogs, modify local files, and etc.

You will need to decide if this functionality will work for your situation and allow you to only use the FMS plug-in instead of installing the client plug-in on each FMP computer. This functionality is also harder to develop with, so it is only recommended for more experienced FileMaker developers.

If you are going to use the Server Version, continue to the server plug-in download section.