Product Logo

CNS Barcode

Scan and Generate Barcodes


Introduction

What is CNS Barcode?

CNS Barcode for FileMaker Pro is a plug-in that brings the power of barcodes to your FileMaker Solution. Like its sibling product, CNS Barcode for iOS, this plug-in can both scan and generate barcodes. CNS Barcode can scan JPEG or PNG images containing barcodes or it can use an attached webcam to scan any barcodes held up to the camera. Any of the barcode formats you can scan, you can also create with the plug-in, including Code 3 of 9 (Code 39), Code 3 of 9 Ext. (Code 39+), Code 93, Code 128, DataBar–14, DataBar–14 Stacked, EAN 2, EAN 5, EAN 13, EAN 14, EAN 128, Interleaved 2 of 5, ISBN, QR Code, UPC A, and UPC E.

Whether you already have products with barcodes or if you want to start using barcodes to track you assets, CNS Barcode is easy to set up and use. If you need to create barcodes, the CNSBC_Generate function will take any data you have in your database and create a PNG image of the barcode format of your choosing. You can then print out and affix the barcodes to the objects you need to track. When you need to scan one of your barcodes, the CNSBC_ScanWindow function will bring up a video preview of your webcam for you to see what you are scanning. When the plug-in recognizes the barcode, it will use one of three actions that you define. It can close the scanning window and return the barcode data to the script that opened the window; it can call a script in you database and pass it the barcode data; or it can set a field in your database with the barcode data. Unlike the first action, the script calling and field setting actions leave the scanning window open for you to scan more barcodes.

So download CNS Barcode today and see how easy it is to add barcodes to your FileMaker Solution.

FileMaker Client Requirements

7.0v3, 8.x, 9.x, 10.x, 11.x, 12.x, 13.x, 14.x (32), 14.x (64), 15.x (32Win), 15.x (64), 16.x (32Win), 16.x (64)

FileMaker Server Requirements

9.x, 10.x, 11.x, 12.x, 13.x, 14.x, 15.x, 16.x

Mac Requirements

10.5, 10.6, 10.7, 10.8, 10.9, 10.10, 10.11, 10.12

Win Requirements

2000, XP, Vista, 7, 8, 10, Microsoft .NET Framework 3.5 Service Pack 1, Microsoft Visual C++ 2010 Redistributable Package

General

A general knowledge of FileMaker scripting and using the calculation engine is needed to use a FileMaker plug-in.


Current Version

2.5.0